System Requirements
Your device is required to meet the following requirements for using the app.
for Phones: iOS 13 or newer Android 8.1 or newer
for Computers: Windows 10 or newer macOS Catalina or newer
for Browsers: Google Chrome 88 or newer Microsoft Edge 88 or newer Mozilla Firefox 78 or newer Apple Safari 13 or newer
※ For Android phones without installing Google Mobile Service (eg. HuaWei) are not supported. A VPN app is required to use Hearty Journal in China.
Last modified 4mo ago
Copy link